Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • 0
xScorpion

Problemas despues de instalar

Question

Use el archivo de @Alucard "database.zip", el cual funciono e instalo correctamente, pero el problema es que la tabla u_perfil no genera contenido, o sea si hay usuarios que se registren lo van a poder hacer correctamente pero no van a poder editar su cuenta ya que no realiza cambios.

 

Otro problema es en muro, si se le intenta subir una imagen, link o video ej:
Field 'a_url' doesn't have a default value
Field 'a_img' doesn't have a default value
Field 'a_desc' doesn't have a default value

 

También probe varios instaladores, le cambie la versión del php y nada, ya no sé que hacer!

 

URL: https://gamesfull.ga
USUARIO: demo
CONTRASEÑA: demodemo

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 2

tienes que cambiar las columnas que te den ese error y ponerle un valor predeterminado

ejemplo

ALTER TABLE `u_muro_adjuntos` CHANGE `a_url` `a_url` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT '\'\'';

ALTER TABLE `u_muro_adjuntos` CHANGE `a_img` `a_img` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT '\'\'';

o usa este instalador con una db nueva

https://www.mediafire.com/file/8uqkxtqayh8nusa/Phpost_install_2019.zip/file

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hola xScorpion, disculpa mi ignorancia pero el archivo database.zip es el script completo? No lo he visto, pero si utilizas el script normal deberías descargarlo sin modificaciones, yo te recomiendo el siguiente post:

Miguel92 subió esa actualización junto con la elección de reCaptcha, a mí me funcionó bastante bien y te lo recomiendo, pruébalo y comenta si te funcionó.

 

Saludos

 

 

Share this post


Link to post
Share on other sites
  • 0

Tampoco entiendo muy bien el problema pero con lo que te dijo Tuente lo solucionas ya que esa versión de miguel está actualizada y es compatible con php 7.1 hacia arriba si no me equivoco.

Share this post


Link to post
Share on other sites
  • 0
hace 7 horas, bits4me dijo:

tienes que cambiar las columnas que te den ese error y ponerle un valor predeterminado

ejemplo

ALTER TABLE `u_muro_adjuntos` CHANGE `a_url` `a_url` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT '\'\'';

ALTER TABLE `u_muro_adjuntos` CHANGE `a_img` `a_img` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL DEFAULT '\'\'';

o usa este instalador con una db nueva

https://www.mediafire.com/file/8uqkxtqayh8nusa/Phpost_install_2019.zip/file

Gracias, muchas gracias

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Patrocinador



  • ×