Jump to content
  • 0
Guest Puppet

Cambiar el line-height a los posts en tema default

Pregunta

Guest Puppet

Hola gente, quisiera que me ayudaran a cambiar el line-height de los posts en el tema default.

Cuando cambio el tamaño de la letra se ve muy junto para mi gusto. Quisiera saber que archivo modificar para poder cambiar este valor.

Segun Inspeccionar Elemento, el line-height esta a 18pt.

 

He aqui a lo que me refiero:

i2qEjSC.png

 

5MdDySi.png

 

PD: La web esta en Localhost.

Compartir este post


Enlace al post
Compartir en otros sitios

13 respuestas a esta pregunta

Recommended Posts

  • 0
Puedes buscar en el archivo m.post_content.tpl lo siguiente:
                            <span>
                                
                                {$tsPost.post_body}
                            
                            </span>

Y dentro del primer <span> agregar un style y quedaría asi:

<span style="line-height: AQUI CAMBIAS EL NUMERO">

Y con eso se estaría cambiando lo que quieres.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Guest Puppet
hace 30 minutos, Tuente dijo:
Puedes buscar en el archivo m.post_content.tpl lo siguiente:
                            <span>
                                
                                {$tsPost.post_body}
                            
                            </span>

Y dentro del primer <span> agregar un style y quedaría asi:

<span style="line-height: AQUI CAMBIAS EL NUMERO">

Y con eso se estaría cambiando lo que quieres.

 

Primero que todo gracias por la respuesta :D, pero... Hice lo que me comentas pero no resulto, el texto sigue igual...

WSAVTAd.png

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 2 minutos, Puppet dijo:

 

Primero que todo gracias por la respuesta :D, pero... Hice lo que me comentas pero no resulto, el texto sigue igual...

WSAVTAd.png

Primero: El <span style="line-height:1.8em"> tenias que reemplazarlo por el que esta arriba del {$tsPost}, no ponerlo debajo :huh: y ponle 20px en vez de 1.8em, esa distancia estaría bien y ponle un !important, que quede asi: line-height: 20px !important; Fijate que tal

Editado por Tuente

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Guest Puppet
hace 3 minutos, Tuente dijo:

Ponle 20px en vez de 1.8em, esa distancia estaría bien y ponle un !important, que quede asi: line-height: 20px !important; Fijate que tal

Lo hice pero sigue igual en los posts D:, que estare haciendo mal?. Ya borre caches e intente entrar desde otro navegador y es lo mismo

NXaVjQZ.png

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 2 minutos, Puppet dijo:

Lo hice pero sigue igual en los posts D:, que estare haciendo mal?. Ya borre caches e intente entrar desde otro navegador y es lo mismo

NXaVjQZ.png

 

Ese código debe quedar asi:

                            <span style="line-height:20px !important;">                                
                                {$tsPost.post_body}
                            </span>

En el código que mostraste debes borrar lo que te marcaré:

                            <span>                                
                                {$tsPost.post_body}
                              	<span style="line-height:20px !important;">  <!-- Borrar esta línea -->
                            </span>

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Guest Puppet
hace 2 minutos, Tuente dijo:

 

Ese código debe quedar asi:

                            <span style="line-height:20px !important;">                                
                                {$tsPost.post_body}
                            </span>

En el código que mostraste debes borrar lo que te marcaré:

                            <span>                                
                                {$tsPost.post_body}
                              	<span style="line-height:20px !important;">  <!-- Borrar esta línea -->
                            </span>

 

 

Listo, pero me temo que no hay cambios...

ieDjVJ8.png

 

Tambien note que el line-height no es fijo, depende el tamaño que le ponga al bbcode [size=] cambia el line-height, no se si tenga algo que ver xD

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 4 minutos, Puppet dijo:

 

Listo, pero me temo que no hay cambios...

ieDjVJ8.png

 

Tambien note que el line-height no es fijo, depende el tamaño que le ponga al bbcode [size=] cambia el line-height, no se si tenga algo que ver xD

Intenta cambiarle el 20px entonces por un numero más grande en px, y si igual depende del tamaño del bbcode jaja

  • Me gusta 1

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Guest Puppet
hace 3 minutos, Tuente dijo:

Intenta cambiarle el 20px entonces por un numero más grande en px, y si igual depende del tamaño del bbcode jaja

Nada, puedes ver directamente el archivo que estoy modificando si gustas :/, quiza este haciendo algo mal

m.posts_content.tpl

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola,prueba esto,deja el archivo m.posts_content.tpl como estaba,tienes que cambiar

<span style="line-height:80px !important;">
{$tsPost.post_body}
</span>


por

<span>
   {$tsPost.post_body}                   
</span>


en estilo.css buscas

.post-contenido {
    word-wrap: break-word;
    font-size: 13px;
    line-height: 1.5em;
}

y ahí le cambias el valor a la propiedad font-size

font-size:13px --> font-size:18px

el valor de la proiedad line-height ,lo dejas igual.

 

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Guest Puppet
hace 11 horas, Tronlar dijo:

Hola,prueba esto,deja el archivo m.posts_content.tpl como estaba,tienes que cambiar

<span style="line-height:80px !important;">
{$tsPost.post_body}
</span>


por

<span>
   {$tsPost.post_body}                   
</span>


en estilo.css buscas

.post-contenido {
    word-wrap: break-word;
    font-size: 13px;
    line-height: 1.5em;
}

y ahí le cambias el valor a la propiedad font-size

font-size:13px --> font-size:18px

el valor de la proiedad line-height ,lo dejas igual.

 

 

 

Hola, hice lo que me comentas y no vi ningun cambio. cambie el valor de la propiedad font-size a 30px para ver si algo cambiaba, y lo unico que cambio fue el control de moderacion del post :/

tSwy5uX.png

SggJcxq.png

 

 

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario


  • Similar Content

    • Por Cj23
      Me gustaria que se creara un MOD de una seccion tienda como este:
      Ese MOD es para la version 1.1, igual adaptandolo a la 1.2 se puede hacer mas sencillo el MOD
       
      Pero que se pueda pagar con $ ya que uso Skylium free y mi sitio aumenta poco a poco (Me gustaria usar algun hosting offshore a poder ser y un dominio .li o .io sino utilizaré un dominio normal y corriente). Asi logro costearme un hosting bueno de pago gracias a la venta de rangos, permisos especiales, posts stickys y demás.
       
      Muchas gracias de antemano!
       
    • Por mardan
      Hola amigos, espero me puedan ayudar con esta consulta. ¿Cómo hago para poder pasar parámetros de un template a una clase?
       
      Dentro de mi clase declaro una función de esta forma:
      function getNumarticulos($cid) con lo cual estoy pidiendo que la función me envió un parámetro, dentro de mi archivo php llamo al método de la siguiente forma:
      $smarty->assign("tsNarticulos",$tsAyuda->getNumarticulos($idc)); aquí es donde entra mi duda, cómo hago para que al momento de llamar al método desde el template pueda pedir el parámetro. Puesto que de momento en el template tengo escrito el código así
      <td style="padding-right:150px;"> <img src="{$tsConfig.images}/icons/folder.png"> <a href="{$tsConfig.url}/ayuda/{$c.c_seo}/" title="{$c.c_nombre}">{$c.c_nombre}</a> ({$tsNarticulos})</td> dónde mi plan es que quedará así con el enviándole un parámetro
      <td style="padding-right:150px;"> <img src="{$tsConfig.images}/icons/folder.png"> <a href="{$tsConfig.url}/ayuda/{$c.c_seo}/" title="{$c.c_nombre}">{$c.c_nombre}</a> ({$tsNarticulos($c.cid)})</td> Si alguien pudiera ayudarme estaría muy agradecido. Saludos!!!!!
    • Por dabarkang
      Buenos días, quiero dar a conocer un problema que vengo teniendo y que no he podido resolver. Pasa que desde hace un tiempo, cada vez que hago un post, la url de estos se generan con ciertas imperfecciones: las comillas son reemplazadas por "quot" y los tildes por "-".
       
      Me explico: si el título del post es por ejemplo: Falleció el "rey del pop", Michael Jackson.
      La url queda así: Falleci-el-quot-rey-del-pop-quot-Michael-Jackson-.html
       
      ¿Me pueden ayudar al menos con el archivo que debo ubicar para tratar de solucionar este problema? Muchas gracias de antemano. 
    • Por unfernacho
      Hola amigos, no funciona el migrador y necesito migrar el archivo c.comunidades de kmario para que todo me funcione correctamente según estuve leyendo en otros temas del foro, alguno lo tiene para poder compartirmelo? por cierto es para el theme default y la web está en mi localhost, muchas gracias
    • Por ferna
      Bueno lo que pasó es que saqué el portal y puse como default al entrar a la página el botón de POSTS, entonces cuando uno esta deslogueado de la página ve el botón con el corner como se muestra en esta imagen:
       

       
      Pero cuando me logueo en la página se ve de la siguiente manera:
       

       
      Quiero que aunque esté logueado el corner se siga viendo porque es un detalle que no quería pasar por alto, por cierto la página la estoy editando en localhost, el theme es el default, muchas gracias 
  • Navegando Recientemente   0 miembros

    No registered users viewing this page.

×