Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

dabarkang

Novato
  • Contenido

    10
  • Mensajes en Chat

    0
  • Registrado

  • Última Visita

Reputación en la Comunidad

0 Neutral

Sobre dabarkang

  • Rango
    Integrado
  1. Mil gracias viejo. Lo último, y no te molesto más. He tenido ciertos problemas para seguir este tutorial. Pasa que quiero que aparezcan las imagenes de portadas en los posts relacionados. Sigo este tutorial pero me quedo en el paso 4. 4. Vamos a m.posts_related.tpl y remplasamos todo por ..." ". Leí en este hilo decir que dicho archivo en este tema es m.posts_relacionados.tpl, así que edité tal archivo en vez del mencionado en este paso. 5. Creamos un archivo llamado m.posts_relacionados.tpl en /themes/TUTEMA/templates/modules/ y agregamos esto, donde dice title-g clearfix cambienlo segun su theme Acá no sé que hacer puesto que si creo un archivo con tal nombre estaría creando un duplicado. ¿Alguna sugerencia? Gracias de nuevo.
  2. Te lo agradecería bastante, capo. Por mientras arreglo el asunto del título de los posts, que no los muestra.
  3. Muy buen trabajo capo. Una consulta, ¿cómo puedo hacer para eliminar los mods que no necesito? Quiero solo lo justo: Mi!, fotos y portadas. Muchas gracias.
  4. dabarkang

    Cambia comillas por quot y tíldes

    Me he topado con estos dos archivos, sin embargo he probado modificarlo sin éxito: soy nulo en php La idea es que las vocales con acento no sean reemplazadas por un guión sino por las mismas pero sin acento. Lo otro, que las comillas no se transformen en "quot" sino que no aparezcan. ¿Algún piadoso? c.core function setSEO($string, $max = false) { // ESPAÑOL $espanol = array('á','é','í','ó','ú','ñ'); $ingles = array('a','e','i','o','u','n'); // MINUS $string = str_replace($espanol,$ingles,$string); $string = trim($string); $string = trim(preg_replace('/[^ A-Za-z0-9_]/', '-', $string)); $string = preg_replace('/[ \t\n\r]+/', '-', $string); $string = str_replace(' ', '-', $string); $string = preg_replace('/[ -]+/', '-', $string); // if($max) { $string = str_replace('-','',$string); $string = strtolower($string); } // return $string; } modifier.seo function smarty_modifier_seo($string){ // ESPAÑOL $espanol = array('á','é','í','ó','ú','ñ'); $ingles = array('a','e','i','o','u','n'); // MINUS $string = str_replace($espanol,$ingles,$string); $string = trim($string); $string = trim(preg_replace("/[^ A-Za-z0-9_]/", "-", $string)); $string = preg_replace("/[ \t\n\r]+/", "-", $string); $string = str_replace(" ", "-", $string); $string = preg_replace("/[ -]+/", "-", $string); // return $string; }
  5. dabarkang

    Cambia comillas por quot y tíldes

    Busqué antes de hacer este hilo, pero no pillé la solución. ¿Me ayudas con el thread en cuestión si no es mucha la molestia? Gracias.
  6. dabarkang

    Cambia comillas por quot y tíldes

    Buenos días, quiero dar a conocer un problema que vengo teniendo y que no he podido resolver. Pasa que desde hace un tiempo, cada vez que hago un post, la url de estos se generan con ciertas imperfecciones: las comillas son reemplazadas por "quot" y los tildes por "-". Me explico: si el título del post es por ejemplo: Falleció el "rey del pop", Michael Jackson. La url queda así: Falleci-el-quot-rey-del-pop-quot-Michael-Jackson-.html ¿Me pueden ayudar al menos con el archivo que debo ubicar para tratar de solucionar este problema? Muchas gracias de antemano.
  7. dabarkang

    ¿Añadir atributo rel="nofollow" a enlaces externos?

    ¿Algún usuario sabe de algún fix para añadir automáticamente el atributo rel=nofollow a los enlaces externos que insertamos en los posts? Busqué en el foro pero no encontré ningún hilo con una solución funcionando. Muchas gracias de antemano.
  8. dabarkang

    Carga lenta de imagenes simultaneas en buena cantidad

    Preferiría que los visitantes vean de golpe las imagenes, pero muchas gracias por la idea, la voy a tener en cuenta. Haciendo esa pequeña modificación de código el cambio de velocidad de carga de dichos posts es asombrosa, gracias por el fix ¿Crees que pueda tener posibles problemas de seguridad por esta modificación? Gracias.
  9. dabarkang

    Carga lenta de imagenes simultaneas en buena cantidad

    Diste en el clavo, ese es el problema. Estuve leyendo en el foro, específicamente el siguiente hilo, y es específicamente el validador del bbcode [img] el lento, tanto así que si lo quito del bbcode.inc.php llega a volar la carga de posts con varias imagenes. Lamentablemente, si lo quito por lo que noto, dejo la pista libre para cualquier ataque xss. Una lástima porque pretendía armar una comunidad dónde básicamente la mayoría iban a ser posts con varias imágenes y esperar 8 segundos de carga entre cada uno espanta a cualquiera ¿Cómo es eso?
  10. dabarkang

    Carga lenta de imagenes simultaneas en buena cantidad

    Me sucede lo siguiente en mi experiencia con phopost: Cuando un post debe cargar más de 3 o 4 imagenes alojadas en servidores externos, noto que demora al menos unos 5 segundos o más en responder y acceder al post, lo que parece excesivo para cualquiera. (Actual instalación limpia de phopost en su última versión disponible en el hosting gratuito hostinger.es) Post con una imagen y un par de líneas (Carga normal sin problemas, similar a cualquier otro script o gestor de contenidos) http://bardinga.tk/posts/noticias/3/Post-con-una-imagen.html Post con diez imagenes (Acá comienzan los problemas. tarda segundos bastante molestos en responder sin apenas antes de que aparezca el post) http://bardinga.tk/posts/imagenes/2/Post-con-diez-imagenes.html Post con veinte imagenes (Prácticamente similar, varios segundos antes de que siguiera comience a visualizarse el post) http://bardinga.tk/posts/imagenes/4/Post-con-veinte-imagenes.html Obviamente, antes siquiera de molestar a alguien acá y pedir ayuda, hice varias pruebas para descartar en lo posible que se tratase de un problema mío y no de phpost: - Para descartar que sea problema de una plantilla en concreto, probé utilizando diferentes plantillas que descargué desde acá + la nativa. También hice uso de las versiones 1.2.7, 1.2.6 y 1.2.5 de phpost. Todas arrojan el mismo problema. - Probé con dominio .net y dominio gratuito .tk - Probé con mi hosting compartido de pago de recursos medios-altos. Así mismo también probé con un hosting gratuito. En ambos está presente el mismo problema. - Probé desde otro proveedor de internet para descartar que sea problema de mi net. Lo mismo. - Probé instalar en ambos domimios otros gestores de contenido, foros y script para despejar la duda que sea un problema de los hosting que utilizo o de phopost. (Tanto en SMF y mybb la carga de los posts con varias imagenes es casi inmediata, incluso con cientos de ellas; En Wordpress, Drupal y Joomla a velocidad de rayo; En un script basado en taringa llamado "Babbel", también la carga de posts con varias imagenes es casi inmediata). Después de todas esas pruebas, a menos que se me haya pasado algo sin darme cuenta, podría atreverme a decir que la deficiencia está en phpost. Hago este posts para ver si pueden ayudarme de alguna manera y que comprueben haciendo la prueba en sus páginas en phpost por favor. En una de esas la deficiencia está de mi lado y no me he dado cuenta. Muchas gracias.
×