Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

jorge51

Ágata
  • Content Count

    363
  • Posts on chatbox

    0
  • Joined

  • Last visited

Community Reputation

81 Amistoso

5 Followers

About jorge51

  • Rank
    Doscientospiés
  • Birthday 10/21/1980

Recent Profile Visitors

2294 profile views
  1. jorge51

    Optimizar consulta de recomendación

    Te paso lo que esta en c.comunidades sobre esta funcion // Notificar a los seguidores de la comunidad, tema function setFollowNotificacion($notType, $f_type, $user_id, $obj_uno, $obj_dos = 0, $excluir){ global $tsCore, $tsMonitor; # A todos los seguidores if($f_type == 1) $obj_uno = $user_id; # Quienes sigan la comunidad/tema $query = db_exec(array(__FILE__, __LINE__), 'query', 'SELECT f_user FROM u_follows WHERE f_id = \''.(int)$obj_uno.'\' AND f_type = \''.(int)$f_type.'\''); $data = result_array($query); // foreach($data as $key => $val){ if(!in_array($val['f_user'],$excluir)){ $tsMonitor->setNotificacion($notType, $val['f_user'], $user_id, $obj_dos); } } // return true; }
  2. jorge51

    Optimizar consulta de recomendación

    Te molesto nuevamente , si te rompo los huevos me lo decis y no te jodo mas otra de las notis que sobrecargan es de comunidades cuando se crea un nuevo tema la funcion es esta $this->setFollowNotificacion(50, 4, $tsUser->uid, $comid, $temaid); y lo puse asi db_exec(array(__FILE__, __LINE__), 'query', " INSERT INTO u_monitor (user_id, obj_user, obj_uno, obj_dos, obj_tres, not_type, not_date) SELECT f_user, '{$tsUser->uid}', '{$temaid}', 0, 0, 50, ".time()." FROM u_follows WHERE f_id = '{$tsUser->uid}' AND f_type = 1 "); funciona bien pero me quedo afuera $comid y no se como ponerlo , la noti sale bien con el tema agregado pero no muestra en que comunidad se agrego
  3. jorge51

    Optimizar consulta de recomendación

    Genio , funciona perfecto , y esto mismo aplicaría para las demás notificaciones masivas , como fotos , cambios de estado y comunidades . Es una gran mejora , muchas gracias
  4. jorge51

    Optimizar consulta de recomendación

    Esto funciona perfecto , se quedaba un rato largo pensando Cuando agregas un post pasa lo mismo , con muchos seguidores se hace casi imposible publicar un post .. Creo que el problema es similar al que solucionaste Esta linea esta en c.post // AGREGAR AL MONITOR DE LOS USUARIOS QUE ME SIGUEN // $tsMonitor->setFollowNotificacion(5, 1, $tsUser->uid, $postID); ¿como se podria mejorar ? Gracias
  5. Gracias por responder , me parece lógica la modificación ya que cuando tenes post con muchos comentarios ( 1000 o mas ) como es mi caso es un embole ir a la ultima pagina para responder , tambien estaria bueno en que se pueda decidir la cantidad máxima de comentarios a mostrar en los post , una pagina que va bien no hay servidor de medio pelo que se lo banque .. Saludos
  6. Hola Miguel ¿ vos sabrias como hacer para invertir el orden en que se muestran los comentarios ? o sea que el ultimo comentario que se hace en un post aparezca arriba de todo en la primera pagina de comentarios Saludos
  7. jorge51

    Nueva vulnerabilidad en Phpost

    En principio no es una copia de tu sitio , es simplemente una redireccion , podes crear contenido porque en realidad estas en tu web , te lo digo porque a mi me paso .. Como lo solucione ?? en tu cpanel debes tener alguna utilidad de estadisticas de vistantes , entra a tu web (desde la url que NO ES LA TUYA) a algun post viejo y en el cpanel revisa desde que ip se accedio a ese post , luego bloqueas esa IP en el cpanel o en mi caso lo hice en el firewall de cloudflare .. , asegurate de entrar al el post desde la pagina trucha , si no te vas a bloquear solo ..
  8. Muy bien por seguir con esto , voy a probar esta versión , y ya que aceptas sugerencias , seria bueno el poder asignar permisos a usuarios para poder editar dicho catalogo , el que se pueda desde la admin es una carga pesada para el administrador ... Gracias por compartirlo
  9. jorge51

    Theme Carbon v1.0 (responsive)

    Esta excelente , Gracias
  10. Muy buen fix , si que era un problema eso y es cierto que viene de arrastre , mira cuantas me guardaba , no tomaba el maximo que se indicaba , lo hacia por tiempo .. Gracias
  11. jorge51

    Ayuda Porfavor :(

    No creo que sea la mejor solucion la que puse , que solo afecta a los contenidos de los post y comentarios nuevos con videos , pero el problema sigue estando , no funciona en el muro y tampoco en comentarios viejos ni en temas creados en comunidades anteriormente (uso las de Kmario) y te repito , espero que alguno de los que realmente saben de esto aporten una solución mejor .. Saludos
  12. jorge51

    Ayuda Porfavor :(

    Disculpa pero me falto un paso , en bbcode.inc.php la linea para video tiene que estar asi array("swf", "/(?i)\[swf\=(.+?)\]/i", "<iframe width=\"640\" height=\"360\" src=\"\\1\" frameborder=\"0\" allowfullscreen></iframe>"), La pega de esto es que no me funciona con las comunidades
  13. jorge51

    Ayuda Porfavor :(

    Olvidate y no le des bola a toda la huevada que puse antes en c.post.php busca $postData['post_body'] = str_replace("http://i.i.","http://i.",$postData['post_body']); y arriba pone $postData['post_body'] = str_replace("http://www.youtube.com/v/","http://www.youtube.com/embed/",$postData['post_body']); Y para que también funcione en comentario si tenes que editar acciones.js h.replaceWith = '[align=center][swf=http://www.youtube.com/v/' + msg + '] Por h.replaceWith = '[align=center][swf=http://www.youtube.com/embed/' + msg + '] De esta forma me funciona en localhost , y esperando a ver si alguien da otra solucion para aplicarlo en la web
  14. jorge51

    Ayuda Porfavor :(

    Quedate tranquilo que no es alguna macana que te mandaste , a mi me pasa lo mismo desde ayer , Solo se pueden ver usando Firefox lo curioso que el video en la home si funciona Me uno a tu pedido de ayuda Edit.. Una forma que conseguí para que funcione (no se si es la solucion correcta ) es en acciones.js cambiar h.replaceWith = '[align=center][swf=http://www.youtube.com/v/' + msg + '] por h.replaceWith = '[align=center][swf=http://www.youtube.com/embed/' + msg + '] Esto haria que en los post nuevos si funcione (tambien comentarios) , y para lo anterior habria que insertar un replacement en c.post.php Pero como no estoy seguro , espero a ver si alguien da otra solucion
  15. jorge51

    Ayuda Porfavor :(

    Quedate tranquilo que no es alguna macana que te mandaste , a mi me pasa lo mismo desde ayer , Solo se pueden ver usando Firefox lo curioso que el video en la home si funciona Me uno a tu pedido de ayuda
×